Error in config.php It doesn´t read english.php lang. file

Support issues for DGS Search

Moderator: DGS Search Developer

Error in config.php It doesn´t read english.php lang. file

Postby pontxo_manzanilla » Fri Jun 04, 2004 5:27 pm

Hi:

I´m making a site with the dgssearch. For my local use, I´m using apache with mySQL. In local with apache, there are no errors, but when I upload the folder with the dgssearch I have this error:

Error: Configuration error(s) in config.php. Details below:

Unable to access language 'english' (dgssearch/libs/language/english.php).

I configured the debug mode to appear the results in the page and the result is:

Debug: main() - Calling processConfig()
>Debug: processConfig()
->Debug: normalizeConfig()
->Debug: loadLanguage() - Checking language pack 'english' stored in 'dgssearch/libs/language/english.php'. [Not Readable]
Error: Configuration error(s) in config.php. Details below:

Unable to access language 'english' (dgssearch/libs/language/english.php).


\nDebug: main() - Total Time: 0.0


I think the config.php is OK. Will the error be in english.php?

Anybody can help me please?


Thanks.
pontxo_manzanilla
 

Postby sella » Sat Jun 05, 2004 7:54 pm

The $config['installBase'] is likely wrong.

The other possiblities are that your install is missing files, such as the english.php file, or that the permissions are set so your web server can't access them. Most web servers run as the user 'nobody'.
User avatar
sella
Site Admin
 
Posts: 81
Joined: Sat Jan 17, 2004 6:53 pm
Location: Denver, CO

Re: Error in config.php It doesn´t read english.php lang. fi

Postby judgedredd » Mon Dec 26, 2016 8:46 am

Hi, I have just spent the last hour or two installing this script and trying to get it to work. I have the exact same error come up as the OP. I have noted the response and made changes to the config.php file to make sure everything works and even changed the permissions of the file on the server itself to see if that would change anything. Nothing. It still comes up with the same error message.

To me this means that there is a problem that has nothing to do with the location of where the script is as I have checked it many times, even looking up things online to see if I understand what is being said.

There needs to be an explanation of why this does not work in my instance. Saying
The $config['installBase'] is likely wrong
without giving an example of a correct one is what I would like to see rectified. I have PHP 5.4 running on my server. Is there something that needs to be changed in the php.ini file?

At the moment my installation of dgssearch is here:
Code: Select all
$config['installBase']      = 'liferepairspecialist.com/another_directory_name/dgssearch/';
$config['urlBase']           = 'http://www.liferepairspecialist.com/';
$config['siteBase']          = 'http://liferepairspecialist.com/another_directory_name/'; 
$config['fsBase']            = 'another_directory_name/'; 
judgedredd
 
Posts: 1
Joined: Mon Dec 26, 2016 8:21 am


Return to DGS Search

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron